This project is read-only.

First silverlight app

Aug 26, 2008 at 6:45 AM
Where does one put the xap, and how do you point to it in the Silverlight settings.

I have tried putting alonside the dll but to no avail.

I am very green with Moss, silverlight is not a problem.

Greg Farquhar
Sep 12, 2008 at 5:43 PM
Someone can explain how it works please!!!??? It's the most important!!!
Sep 26, 2008 at 2:56 AM
There are many ways you can approach this.
1. Put it into a list and reference the xap from the sharepoint list.
2. Create a virtual directory and put the xap there and reference it there.

Make sure you define the path to the xap. with (/) and not (\)
Oct 5, 2008 at 2:18 PM
I don't exactly understand your solution. I want to use SilverPart to display a SilverLight app. I have added a SilverPart to my MOSS site, and copied my xap file to 'C:\Inetpub\wwwroot\wss\VirtualDirectories\80' How can I refer this file in the Silverlight settings? Do I need to save the file on other location? I've also tried adding it to a SharePoint list and referenced it from it, but doesn't work.

Thank you for your help
Dec 8, 2008 at 12:55 PM
the webpart installs correctly but I am unable to use it in moss2007. it does not show up in the webparts gallery.
Jan 30, 2009 at 1:32 PM
When you say it doesnt appear in the webparts gallery have you tried adding it?

In the webparts gallery click New. Then on the next page you should be able to find the SilverPart.SilverPartWebPart listed.
Check the box next to the entry and then click on the  Populate Gallery button.

The webpart should now be availabe for use.
Feb 1, 2009 at 4:39 AM
Edited Feb 1, 2009 at 4:40 AM
Also make sure the SilverPart 2.0 feature is activated. 

Go to Site Settings -> Site Collection Features -> Activate
Mar 14, 2009 at 7:17 AM
How can I refer .xap file in the SilverPart settings?
May 7, 2009 at 7:46 AM
I have create a special library for xap-files and refers to it. SilverPart works fine!